CVE and update status of the FreeBSD ports tree3,295 unaddressed CVEs in 670 portsAll times are CET
CVE details

CVE-2024-47887

Action Pack is a framework for handling and responding to web requests. Starting in version 4.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in Action Controller's HTTP Token authentication. For applications using HTTP Token authentication via `authenticate_or_request_with_http_token` or similar, a carefully crafted header may cause header parsing to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may choose to use Ruby 3.2 as a workaround.Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.

Score
6.6 medium
Published
2024-10-16
Links
NVD · cve.org

Matched ports (5)

PortPackageVersionStatusMaintainer
www/rubygem-rails4rubygem-rails44.2.11.3unaddressedsunpoet@FreeBSD.org
www/rubygem-rails5rubygem-rails55.1.7_2unaddressedruby@FreeBSD.org
www/rubygem-rails50rubygem-rails505.0.7.2_2unaddressedruby@FreeBSD.org
www/rubygem-rails52rubygem-rails525.2.8.1unaddressedsunpoet@FreeBSD.org
www/rubygem-rails60rubygem-rails606.0.6.1_2unaddressedsunpoet@FreeBSD.org

Template for a VuXML entry

Range taken from the CVE record, check it before committing. make newentry in security/vuxml creates the vid.

  <vuln vid="FIXME (make newentry)">
    <topic>FIXME -- FIXME</topic>
    <affects>
      <package>
	<name>rubygem-rails4</name>
	<range><lt>6.1.7.9</lt></range>
      </package>
      <package>
	<name>rubygem-rails5</name>
	<range><lt>6.1.7.9</lt></range>
      </package>
      <package>
	<name>rubygem-rails50</name>
	<range><lt>6.1.7.9</lt></range>
      </package>
      <package>
	<name>rubygem-rails52</name>
	<range><lt>6.1.7.9</lt></range>
      </package>
      <package>
	<name>rubygem-rails60</name>
	<range><lt>6.1.7.9</lt></range>
      </package>
    </affects>
    <description>
      <body xmlns="http://www.w3.org/1999/xhtml">
	<p>Action Pack is a framework for handling and responding to web
	requests. Starting in version 4.0.0 and prior to versions 6.1.7.9,
	7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability
	in Action Controller's HTTP Token authentication. For applications
	using HTTP Token authentication via
	`authenticate_or_request_with_http_token` or similar, a carefully
	crafted header may cause header parsing to take an unexpected amount
	of time, possibly resulting in a DoS vulnerability. All users running
	an affected release should either upgrade to versions 6.1.7.9,
	7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately.
	One may choose to use Ruby 3.2 as a workaround.Ruby 3.2 has
	mitigations for this problem, so Rails applications using Ruby 3.2 or
	newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater
	so is unaffected.</p>
      </body>
    </description>
    <references>
      <cvename>CVE-2024-47887</cvename>
      <url>https://nvd.nist.gov/vuln/detail/CVE-2024-47887</url>
    </references>
    <dates>
      <discovery>2024-10-16</discovery>
      <entry>2026-10-26</entry>
    </dates>
  </vuln>