CVE details
CVE-2025-47940
TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
- Score
- 7.2 high
- Published
- 2025-05-20
- Links
- NVD · cve.org · Report wrong data
Matched ports (5)
| Port | Package | Version | Status | Maintainer |
|---|---|---|---|---|
| www/typo3-11 | typo3-11-php82 | 11.5.40_1 | unaddressed | freebsd-ports@charlieroot.de |
| www/typo3-11 | typo3-11-php83 | 11.5.40_1 | unaddressed | freebsd-ports@charlieroot.de |
| www/typo3-11 | typo3-11-php84 | 11.5.40_1 | unaddressed | freebsd-ports@charlieroot.de |
| www/typo3-11 | typo3-11-php85 | 11.5.40_1 | unaddressed | freebsd-ports@charlieroot.de |
| www/typo3-11 | typo3-11-php86 | 11.5.40_1 | unaddressed | freebsd-ports@charlieroot.de |
Template for a VuXML entry
Range taken from the CVE record, check it before committing. make newentry in security/vuxml creates the vid.
<vuln vid="FIXME (make newentry)">
<topic>FIXME -- FIXME</topic>
<affects>
<package>
<name>typo3-11-php82</name>
<range><lt>10.4.50</lt></range>
</package>
<package>
<name>typo3-11-php83</name>
<range><lt>10.4.50</lt></range>
</package>
<package>
<name>typo3-11-php84</name>
<range><lt>10.4.50</lt></range>
</package>
<package>
<name>typo3-11-php85</name>
<range><lt>10.4.50</lt></range>
</package>
<package>
<name>typo3-11-php86</name>
<range><lt>10.4.50</lt></range>
</package>
</affects>
<description>
<body xmlns="http://www.w3.org/1999/xhtml">
<p>TYPO3 is an open source, PHP based web content management system.
Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44
ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users
without system maintainer privileges can escalate their privileges and
gain system maintainer access. Exploiting this vulnerability requires
a valid administrator account. Users should update to TYPO3 version
10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the
problem.</p>
</body>
</description>
<references>
<cvename>CVE-2025-47940</cvename>
<url>https://nvd.nist.gov/vuln/detail/CVE-2025-47940</url>
</references>
<dates>
<discovery>2025-05-20</discovery>
<entry>2026-10-26</entry>
</dates>
</vuln>