CVE details
CVE-2026-120135
Uncontrolled Recursion vulnerability in Apache Thrift Java bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
- Score
- 8.2 high
- Published
- 2026-10-31
- Links
- NVD · cve.org · Report wrong data
Matched ports (7)
| Port | Package | Version | Status | Maintainer |
|---|---|---|---|---|
| devel/node-thrift | node-thrift | 0.22.0_1 | unaddressed | ports@FreeBSD.org |
| devel/p5-Thrift | p5-Thrift | 0.22.0_1,1 | unaddressed | sunpoet@FreeBSD.org |
| devel/rubygem-thrift | rubygem-thrift | 0.22.0,1 | unaddressed | komarov@valerka.net |
| devel/thrift | thrift | 0.22.0,1 | unaddressed | ports@FreeBSD.org |
| devel/thrift-c_glib | thrift-c_glib | 0.22.0,1 | unaddressed | ports@FreeBSD.org |
| devel/thrift-cpp | thrift-cpp | 0.22.0_2,1 | unaddressed | ports@FreeBSD.org |
| devel/py-thrift | py312-thrift | 0.24.0_1,1 | fixed by update | sunpoet@FreeBSD.org |
Template for a VuXML entry
Check the content
Check the version numbers before you commit this entry. Some ports share an entry in the CVE database with another port, such as sqlite2 and sqlite3. The version shown here may then be one that never existed for this port.
Ranges per package from the CVE rows that match this port, in pkg notation with the port's epoch and revision, every bound checked with pkg; one range per epoch the port actually had. make newentry in security/vuxml creates the vid.
<vuln vid="FIXME (make newentry)">
<topic>node-thrift -- FIXME</topic>
<affects>
<package>
<name>node-thrift</name>
<range><lt>0.24.0</lt></range>
</package>
<package>
<name>p5-Thrift</name>
<name>rubygem-thrift</name>
<name>thrift</name>
<name>thrift-c_glib</name>
<name>thrift-cpp</name>
<range><lt>0.24.0,1</lt></range>
</package>
</affects>
<description>
<body xmlns="http://www.w3.org/1999/xhtml">
<p>CVE-2026-120135: Uncontrolled Recursion vulnerability in Apache Thrift
Java bindings. This issue affects Apache Thrift: before 0.24.0.
Users are recommended to upgrade to version 0.24.0, which fixes the
issue.</p>
</body>
</description>
<references>
<cvename>CVE-2026-120135</cvename>
<url>https://nvd.nist.gov/vuln/detail/CVE-2026-120135</url>
</references>
<dates>
<discovery>2026-10-31</discovery>
<entry>2026-11-02</entry>
</dates>
</vuln>