CVE details
CVE-2026-41415
PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an out-of-bounds read when parsing a malformed Content-ID URI in SIP multipart message body. Insufficient length validation can cause reads beyond the intended buffer bounds. This vulnerability is fixed in 2.17.
- Score
- 6.7 medium
- Published
- 2026-04-24
- Links
- NVD · cve.org · Report wrong data
Matched ports (1)
| Port | Package | Version | Status | Maintainer |
|---|---|---|---|---|
| net/pjsip | pjsip | 2.14.1 | unaddressed | oliver.epper@gmail.com |
Template for a VuXML entry
Range taken from the CVE record, check it before committing. make newentry in security/vuxml creates the vid.
<vuln vid="FIXME (make newentry)">
<topic>FIXME -- FIXME</topic>
<affects>
<package>
<name>pjsip</name>
<range><lt>2.17</lt></range>
</package>
</affects>
<description>
<body xmlns="http://www.w3.org/1999/xhtml">
<p>PJSIP is a free and open source multimedia communication library
written in C. In 2.16 and earlier, there is an out-of-bounds read when
parsing a malformed Content-ID URI in SIP multipart message body.
Insufficient length validation can cause reads beyond the intended
buffer bounds. This vulnerability is fixed in 2.17.</p>
</body>
</description>
<references>
<cvename>CVE-2026-41415</cvename>
<url>https://nvd.nist.gov/vuln/detail/CVE-2026-41415</url>
</references>
<dates>
<discovery>2026-04-24</discovery>
<entry>2026-10-26</entry>
</dates>
</vuln>