Upgrade to 3.12.9. PR: ports/168719 Required by: Paul Dokas <paul@dokas.name>951517b000
node, iojs, and v8 -- denial of serviceentered 2015-07-06
Open source JavaScript engine by Google
# pkg install v8installs 15.5.35.25 from latest; from quarterly (2026Q4) 10.4.132.20_4# cd /usr/ports/lang/v8 && make install clean| FreeBSD version | amd64 | aarch64 | i386 |
|---|---|---|---|
| FreeBSD 16 | 15.5.35.25 | 15.5.35.20_1 | – |
| FreeBSD 15 | 15.5.35.25 | 15.5.35.25 | – |
| FreeBSD 14 | 15.5.35.25 | ✗ | 15.5.35.25 |
| FreeBSD version | amd64 | aarch64 | i386 |
|---|---|---|---|
| FreeBSD 15 | 10.4.132.20_4 | ✗ | – |
| FreeBSD 14 | 10.4.132.20_4 | ✗ | 10.4.132.20_4 |
version as in the ports tree (latest) or the most common one (quarterly) · different version · ✗ not built · – no packages for this platform. Package sets that have not been rebuilt for 60 days are left out.
The CVE record lists the packaged version 15.5.35.25 as affected, and no VuXML entry names the CVE. What does this mean?
| CVE | CVSS | Published | Description |
|---|---|---|---|
| CVE-2024-1939 | 8.8 | 2024-02-29 | Type Confusion in V8 in Google Chrome prior to 122.0.6261.94 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security… |
Listed in VuXML, the packaged version 15.5.35.25 is still in the affected range; pkg audit reports it. What does this mean?
| PR | Summary | Status | Changed |
|---|---|---|---|
| 271838 | lang/v8: fails with kern.elf64.allow_wx=0 but elfctl -e +wxneeded doesn't help | New | 2026-07-01 |
Upgrade to 3.12.9. PR: ports/168719 Required by: Paul Dokas <paul@dokas.name>951517b000
Upgrade to 3.11.8.99f7bbb54f
Upgrade to 3.11.2.ad8311e37c
Upgrade to 3.10.4.bec37314cf
Upgrade to 3.9.5.fee6eeef9f
Upgrade to 3.8.5.8676d59fe3
1: Upgrade to 3.8.2. 2: handle '-fno-strict-aliasing'. PR: ports/163606 Submitted by: Panagiotis Christias <p.christias at noc.ntua.gr> [2]63bb7c8fb5
Upgrade to 3.7.3.613870a936
Fix build error with clang.492bb0cb59
Upgrade to 3.5.10.b864d712bc
Upgrade to 3.5.1.13d735490e
Upgrade to 3.4.8.b3a42e2589
1: Upgrade to 3.4.4 2: install shared library by default. 3: resolv undefined symbol. PR: ports/157875 Submitted by: Brett Kiefer <brett at fogcreek.com>, L Campbell <lcampbell at ironclad.mobi> [3]80c75c68ce
Fix overkill for everytime changing GITVERSION and depends on it WRKSRC. Approved by: vanilla3f0d48c4ba
Upgrade to 3.4.1.966628c849
Upgrade to 3.3.8.8de6f0c600
add missing depends to devel/libexecinfo. PR: ports/156993 Submitted by: L Campbell <lcampbell at ironclad.mobi>7923d9443b
Add v8 3.2.8, google\'s open source JavaScript engine. PR: ports/152175 Submitted by: siasia867c93ee02