net/rubygem-omniauth-google-oauth2-gitlab: update to 1.2.2 Required for gitlab 18.11 Changes: https://github.com/zquestz/omniauth-google-oauth2/releases4fc1b63dc6
Port details
net/rubygem-omniauth-google-oauth2-gitlab 1.2.2
Google OAuth2 strategy for OmniAuth 1.x
Port info
- Maintainer
- mfechner@FreeBSD.org
- Packages
- latest: 1.2.2
- Upstream
- up to date
- Last update
- to 1.2.2 · 4fc1b63dc6
- Quarterly
- 2026Q4: 1.2.2
- WWW
- https://github.com/zquestz/omniauth-google-oauth2
- Links
- cgit · VuXML · Report wrong data
Install
- Package
# pkg install rubygem-omniauth-google-oauth2-gitlabinstalls 1.2.2 fromlatest; fromquarterly(2026Q4) 1.2.2- Port
# cd /usr/ports/net/rubygem-omniauth-google-oauth2-gitlab && make install clean- Size
- 22 KiB download · 90 KiB installed
- Depends on
- devel/ruby-gems 4.0.21, lang/ruby34 3.4.9_2,1, net/rubygem-oauth2-gitlab 2.0.25, net/rubygem-omniauth-oauth2-gitlab 1.9.0, security/rubygem-omniauth-gl 2.1.4_2, www/rubygem-jwt 3.3.0
- License
- MIT
Packages by version and architecture
latest
| FreeBSD version | amd64 | aarch64 | i386 |
|---|---|---|---|
| FreeBSD 16 | 1.2.2 | 1.2.2 | – |
| FreeBSD 15 | 1.2.2 | 1.2.2 | – |
| FreeBSD 14 | 1.2.2 | 1.2.2 | 1.2.2 |
quarterly (2026Q4)
| FreeBSD version | amd64 | aarch64 | i386 |
|---|---|---|---|
| FreeBSD 15 | 1.2.2 | 1.2.2 | – |
| FreeBSD 14 | 1.2.2 | 1.2.2 | 1.2.2 |
version as in the ports tree (latest) or the most common one (quarterly) · different version · ✗ not built · – no packages for this platform. Package sets that have not been rebuilt for 60 days are left out.
Unaddressed and VuXML only (0)
No unaddressed CVE and nothing reported by
pkg audit for the packaged version 1.2.2.Fixed (0)
No VuXML entries for this package.
Problem reports (0) · open in Bugzilla, most recently changed first
None.
Commits (4)
net/rubygem-omniauth-google-oauth2-gitlab: update to 1.2.1 Required for gitlab 18.6 Changes: https://github.com/zquestz/omniauth-google-oauth2/releases391e4cc052
www/gitlab: fix regression from 5028178941fc081cd43354ea03ceda365a12f73d this fixes a depedency conflict with rubygem-logger which was added into package security/rubygem-omniauth which conflicts with rubygem-logger-gitlab5c2597808c
www/gitlab: fix regression from 335fc7c38d61142727cb9f01fd9e401c476e4ad8 Gitlab requires net-http 0.4.1: Because faraday >= 2, < 2.5 could not be found in locally installed gems and faraday >= 2.5, < 2.12.1 could not be found in locally installed gems, faraday >= 2, < 2.12.1 cannot be used. And because faraday >= 2.12.1 depends on faraday-net_http >= 2.0, < 3.5, faraday >= 2 requires faraday-net_http >= 2.0, < 3.5. Because faraday-net_http >= 3.4.0 depends on net-http >= 0.5.0 and faraday-net_http >= 2.0, < 3.4.0 could not be found in locally installed gems, faraday-net_http >= 2.0 requires net-http >= 0.5.0. Thus, faraday >= 2 requires net-http >= 0.5.0. So, because Gemfile depends on faraday ~> 2 and Gemfile depends on net-http = 0.4.1, version solving has failed. While fixing the problem, moved gitlab used packages to own package names with a PKGNAMESUFFIX of `-gitlab`. This should make the gitlab package much more stable if updates in the ports are done.edc8d0390e