CVE and update status of the FreeBSD ports tree3,864 unaddressed CVEs in 671 portsAll times are CET
Port details

security/p5-Crypt-JWT 0.038

JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516

Maintainer
svysh.fbsd@gmail.com
Packages
latest: 0.038
Upstream
up to date
Last update
to 0.038 · 13c8022fe7
Quarterly
2026Q4: 0.038
WWW
https://metacpan.org/dist/Crypt-JWT
Links
cgit · VuXML

Unaddressed and VuXML only (0)

No unaddressed CVE and nothing reported by pkg audit for the packaged version 0.038.

Fixed (0)

No VuXML entries for this package.

Problem reports (0) · open in Bugzilla, most recently changed first

None.

Commits (10)

Hiroki Tagato (tagattie) · 0.038
security/p5-Crypt-JWT: Update to 0.038 (with security fix)

ChangeLog: https://metacpan.org/dist/Crypt-JWT/changes

PR:		295376
Reported by:	Sergei Vyshenski <svysh.fbsd@gmail.com> (maintainer)
13c8022fe7
Vladimir Druzenko (vvd) · 0.037
security/p5-Crypt-JWT: Update 0.036 => 0.037

ChangeLog:
https://metacpan.org/dist/Crypt-JWT/changes

PR:	286411
32eb7d407b
Vanilla I. Shu (vanilla) · 0.036
security/p5-Crypt-JWT: Update to 0.036.

PR:		284394
Reported by:	maintainer
6bba195213
Robert Clausecker (fuz) · 0.035
security/p5-Crypt-JWT: Update to 0.035

ChangeLog: https://metacpan.org/dist/Crypt-JWT/changes

PR:		274262
813f9362a1
Stefan Eßer (se) · 0.034
Remove WWW entries moved into port Makefiles

Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.

This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.

Approved by:		portmgr (tcberner)
fb16dfecae
Stefan Eßer (se) · 0.034
Add WWW entries to port Makefiles

It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.

Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.

There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.

This commit implements such a proposal and moves one of the WWW: entries
of each pkg-descr file into the respective port's Makefile. A heuristic
attempts to identify the most relevant URL in case there is more than
one WWW: entry in some pkg-descr file. URLs that are not moved into the
Makefile are prefixed with "See also:" instead of "WWW:" in the pkg-descr
files in order to preserve them.

There are 1256 ports that had no WWW: entries in pkg-descr files. These
ports will not be touched in this commit.

The portlint port has been adjusted to expect a WWW entry in each port
Makefile, and to flag any remaining "WWW:" lines in pkg-descr files as
deprecated.

Approved by:		portmgr (tcberner)
b7f05445c0
Tobias C. Berner (tcberner) · 0.034
security: remove 'Created by' lines

A big Thank You to the original contributors of these ports:

  *  <ports@c0decafe.net>
  *  Aaron Dalton <aaron@FreeBSD.org>
  *  Adam Weinberger <adamw@FreeBSD.org>
  *  Ade Lovett <ade@FreeBSD.org>
  *  Aldis Berjoza <aldis@bsdroot.lv>
  *  Alex Dupre <ale@FreeBSD.org>
  *  Alex Kapranoff <kappa@rambler-co.ru>
  *  Alex Samorukov <samm@freebsd.org>
  *  Alexander Botero-Lowry <alex@foxybanana.com>
  *  Alexander Kriventsov <avk@vl.ru>
  *  Alexander Leidinger <netchild@FreeBSD.org>
  *  Alexander Logvinov <ports@logvinov.com>
  *  Alexander Y. Grigoryev <alexander.4mail@gmail.com>
  *  Alexey Dokuchaev <danfe@FreeBSD.org>
  *  Alfred Perlstein
  *  Alfred Perlstein <alfred@FreeBSD.org>
  *  Anders Nordby <anders@FreeBSD.org>
  *  Anders Nordby <anders@fix.no>
  *  Andreas Klemm <andreas@klemm.gtn.com>
  *  Andrew Lewis <freeghb@gmail.com>
  *  Andrew Pantyukhin <infofarmer@FreeBSD.org>
  *  Andrew St. Jean <andrew@arda.homeunix.net>
  *  Anes Mukhametov <anes@anes.su>
  *  Antoine Brodin <antoine@FreeBSD.org>
  *  Anton Berezin <tobez@FreeBSD.org>
  *  Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
  *  Antonio Carlos Venancio Junior <antonio@inf.ufsc.br>
  *  Ashish SHUKLA <ashish@FreeBSD.org>
  *  Attila Nagy <bra@fsn.hu>
  *  Autrijus Tang <autrijus@autrijus.org>
  *  Axel Rau <axel.rau@chaos1.de>
  *  Babak Farrokhi <farrokhi@FreeBSD.org>
  *  Ben Woods <woodsb02@FreeBSD.org>
  *  Bernard Spil <brnrd@FreeBSD.org>
  *  Bernard Spil <brnrd@freebsd.org>
  *  Blaz Zupan <blaz@si.FreeBSD.org>
  *  Bob Hockney <zeus@ix.netcom.com>
  *  Boris Kochergin <spawk@acm.poly.edu>
  *  Brendan Molloy <brendan+freebsd@bbqsrc.net>
  *  Bruce M Simpson
  *  Bruce M Simpson <bms@FreeBSD.org>
  *  Bruce M. Simpson <bms@FreeBSD.org>
  *  Carlo Strub
  *  Carlo Strub <cs@FreeBSD.org>
  *  Carlos J Puga Medina <cpm@FreeBSD.org>
  *  Carlos J Puga Medina <cpm@fbsd.es>
  *  Charlie Root <se@FreeBSD.org>
  *  Cheng-Lung Sung <clsung@FreeBSD.org>
  *  Cheng-Lung Sung <clsung@dragon2.net>
  *  Chie Taguchi <taguchi.ch@gmail.com>
  *  Chris Cowart <ccowart@rescomp.berkeley.edu>
  *  Chris D. Faulhaber <jedgar@FreeBSD.org>
  *  Christer Edwards <christer.edwards@gmail.com>
  *  Christian Lackas
  *  Christopher Hall <hsw@bitmark.com>
  *  Clement Laforet <sheepkiller@cultdeadsheep.org>
  *  Clive Lin <clive@CirX.ORG>
  *  Colin Percival
  *  Cory McIntire (loon@noncensored.com)
  *  Craig Leres <leres@FreeBSD.org>
  *  Cristiano Deana <cris@gufi.org>
  *  Cy Schubert (Cy.Schubert@uumail.gov.bc.ca)
  *  Cy Schubert <Cy.Schubert@uumail.gov.bc.ca>
  *  Cy Schubert <cy@FreeBSD.org>
  *  Damian Gerow <dgerow@afflictions.org>
  *  Damien Bobillot
  *  Dan Langille
  *  Dan Langille <dan@freebsddiary.org>
  *  Dan Langille <dvl@FreeBSD.org>
  *  Dan Langille <dvl@freebsd.org>
  *  Dan Langille <dvl@sourcefire.com>
  *  Daniel Kahn Gillmor <dkg@fifthhorseman.net>
  *  Daniel Roethlisberger <daniel@roe.ch>
  *  Danilo Egea Gondolfo <danilo@FreeBSD.org>
  *  Danton Dorati <urisso@bsd.com.br>
  *  Dave McKay <dave@mu.org>
  *  David E. Thiel <lx@FreeBSD.org>
  *  David O'Brien (obrien@NUXI.com)
  *  David O'Brien <obrien@FreeBSD.org>
  *  David Thiel <lx@redundancy.redundancy.org>
  *  Dean Hollister <dean@odyssey.apana.org.au>
  *  Denis Shaposhnikov <dsh@vlink.ru>
  *  Dereckson <dereckson@gmail.com>
  *  Dirk Froemberg <dirk@FreeBSD.org>
  *  Ditesh Shashikant Gathani <ditesh@gathani.org>
  *  Dom Mitchell <dom@happygiraffe.net>
  *  Dominic Marks <dominic.marks@btinternet.com>
  *  Don Croyle <croyle@gelemna.org>
  *  Douglas Thrift <douglas@douglasthrift.net>
  *  Edson Brandi <ebrandi@fugspbr.org>
  *  Edwin Groothuis <edwin@mavetju.org>
  *  Ekkehard 'Ekki' Gehm <gehm@physik.tu-berlin.de>
  *  Emanuel Haupt <ehaupt@FreeBSD.org>
  *  Emanuel Haupt <ehaupt@critical.ch>
  *  Eric Crist <ecrist@secure-computing.net>
  *  Erwin Lansing <erwin@FreeBSD.org>
  *  Eugene Grosbein <eugen@FreeBSD.org>
  *  Fabian Keil <fk@fabiankeil.de>
  *  Felix Palmen <felix@palmen-it.de>
  *  Florent Thoumie <flz@xbsd.org>
  *  Foxfair Hu <foxfair@FreeBSD.org>
  *  Frank Laszlo <laszlof@vonostingroup.com>
  *  Frank Wall <fw@moov.de>
  *  Franz Bettag <franz@bett.ag>
  *  Gabor Kovesdan
  *  Gabor Kovesdan <gabor@FreeBSD.org>
  *  Gabriel M. Dutra <0xdutra@gmail.com>
  *  Gary Hayers <Gary@Hayers.net>
  *  Gasol Wu <gasol.wu@gmail.com>
  *  Gea-Suan Lin <gslin@gslin.org>
  *  George Reid <greid@ukug.uk.freebsd.org>
  *  George Reid <services@nevernet.net>
  *  Greg Larkin <glarkin@FreeBSD.org>
  *  Greg V <greg@unrelenting.technology>
  *  Gregory Neil Shapiro <gshapiro@FreeBSD.org>
  *  Grzegorz Blach <gblach@FreeBSD.org>
  *  Guangyuan Yang <ygy@FreeBSD.org>
  *  Hakisho Nukama <nukama@gmail.com>
  *  Hammurabi Mendes <hmendes@brturbo.com>
  *  Henk van Oers <hvo.pm@xs4all.nl>
  *  Horia Racoviceanu <horia@racoviceanu.com>
  *  Hung-Yi Chen <gaod@hychen.org>
  *  Jaap Akkerhuis <jaap@NLnetLabs.nl>
  *  Jaap Boender <jaapb@kerguelen.org>
  *  Jacek Serwatynski <tutus@trynet.eu.org>
  *  James FitzGibbon <jfitz@FreeBSD.org>
  *  James Thomason <james@divide.org>
  *  Jan-Peter Koopmann <Jan-Peter.Koopmann@seceidos.de>
  *  Janky Jay <ek@purplehat.org>
  *  Janos Mohacsi
  *  Janos Mohacsi <janos.mohacsi@bsd.hu>
  *  Jean-Yves Lefort <jylefort@brutele.be>
  *  Jim Geovedi <jim@corebsd.or.id>
  *  Jim Ohlstein <jim@ohlste.in>
  *  Joe Clarke <marcus@marcuscom.com>
  *  Joe Marcus Clarke <marcus@FreeBSD.org>
  *  Johann Visagie <johann@egenetics.com>
  *  Johann Visagie <wjv@FreeBSD.org>
  *  John Ferrell <jdferrell3@yahoo.com>
  *  John Hixson <jhixson@gmail.com>
  *  John Polstra <jdp@polstra.com>
  *  John W. O'Brien <john@saltant.com>
  *  John-Mark Gurney <jmg@FreeBSD.org>
  *  Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
  *  Joseph Benden <joe@thrallingpenguin.com>
  *  Joshua D. Abraham <jabra@ccs.neu.edu>
  *  Jov <amutu@amutu.com>
  *  Jui-Nan Lin <jnlin@freebsd.cs.nctu.edu.tw>
  *  Ka Ho Ng <khng300@gmail.com>
  *  Kay Lehmann <kay_lehmann@web.de>
  *  Keith J. Jones <kjones@antihackertoolkit.com>
  *  Kevin Zheng <kevinz5000@gmail.com>
  *  Kimura Fuyuki <fuyuki@hadaly.org>
  *  Kimura Fuyuki <fuyuki@mj.0038.net>
  *  Klayton Monroe <klm@uidzero.org>
  *  Konstantin Menshikov <kostjnspb@yandex.ru>
  *  Koop Mast <kwm@FreeBSD.org>
  *  Kris Kennaway <kris@FreeBSD.org>
  *  Kubilay Kocak <koobs@FreeBSD.org>
  *  Kurt Jaeger <fbsd-ports@opsec.eu>
  *  LEVAI Daniel <leva@ecentrum.hu>
  *  Lars Engels <lme@FreeBSD.org>
  *  Lars Thegler <lth@FreeBSD.org>
  *  Laurent LEVIER <llevier@argosnet.com>
  *  Luiz Eduardo R. Cordeiro
  *  Lukas Slebodnik <lukas.slebodnik@intrak.sk>
  *  Lukasz Komsta
  *  Mageirias Anastasios <anastmag@gmail.com>
  *  Marcel Prisi <marcel.prisi@virtua.ch>
  *  Marcello Coutinho
  *  Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
  *  Mark Felder <feld@FreeBSD.org>
  *  Mark Hannon <markhannon@optusnet.com.au>
  *  Mark Murray <markm@FreeBSD.org>
  *  Mark Pulford <mark@kyne.com.au>
  *  Marko Njezic <sf@maxempire.com>
  *  Martin Matuska <martin@tradex.sk>
  *  Martin Matuska <mm@FreeBSD.org>
  *  Martin Mersberger
  *  Martin Wilke <miwi@FreeBSD.org>
  *  Martti Kuparinen <martti.kuparinen@ericsson.com>
  *  Mateusz Piotrowski <0mp@FreeBSD.org>
  *  Matt <matt@xtaz.net>
  *  Matt Behrens <matt@zigg.com>
  *  Matthias Andree <mandree@FreeBSD.org>
  *  Matthias Fechner <mfechner@FreeBSD.org>
  *  Matthieu BOUTHORS <matthieu@labs.fr>
  *  Maxim Sobolev <sobomax@FreeBSD.org>
  *  Meno Abels <meno.abels@adviser.com>
  *  Michael Haro <mharo@FreeBSD.org>
  *  Michael Johnson <ahze@FreeBSD.org>
  *  Michael Nottebrock <lofi@FreeBSD.org>
  *  Michael Reifenberger <mr@FreeBSD.org>
  *  Michael Schout <mschout@gkg.net>
  *  Michal Bielicki <m.bielicki@llizardfs.com>
  *  Michiel van Baak <michiel@vanbaak.eu
  *  Mij <mij@bitchx.it>
  *  Mike Heffner <mheffner@vt.edu>
  *  Mikhail T. <m.tsatsenko@gmail.com>
  *  Mikhail Teterin <mi@aldan.algebra.com>
  *  Milan Obuch
  *  Mosconi <mosconi.rmg@gmail.com>
  *  Muhammad Moinur Rahman <5u623l20@gmail.com>
  *  Mustafa Arif <ma499@doc.ic.ac.uk>
  *  Neil Booth
  *  Neil Booth <kyuupichan@gmail.com>
  *  Nick Barkas <snb@threerings.net>
  *  Nicola Vitale <nivit@FreeBSD.org>
  *  Niels Heinen
  *  Nikola Kolev <koue@chaosophia.net>
  *  Nobutaka Mantani <nobutaka@FreeBSD.org>
  *  Oliver Lehmann
  *  Oliver Lehmann <oliver@FreeBSD.org>
  *  Olivier Duchateau
  *  Olivier Duchateau <duchateau.olivier@gmail.com>
  *  Olli Hauer
  *  Patrick Li <pat@databits.net>
  *  Paul Chvostek <paul@it.ca>
  *  Paul Schmehl <pauls@utdallas.edu>
  *  Pavel I Volkov <pavelivolkov@googlemail.com>
  *  Pete Fritchman <petef@databits.net>
  *  Peter Ankerstal <peter@pean.org>
  *  Peter Haight <peterh@sapros.com>
  *  Peter Johnson <johnson.peter@gmail.com>
  *  Peter Pentchev <roam@FreeBSD.org>
  *  Petr Rehor <rx@rx.cz>
  *  Philippe Audeoud <jadawin@tuxaco.net>
  *  Philippe Rocques <phil@teaser.fr>
  *  Piotr Kubaj <pkubaj@FreeBSD.org>
  *  Piotr Kubaj <pkubaj@anongoth.pl>
  *  Po-Chuan Hsieh <sunpoet@FreeBSD.org>
  *  RaRa Rasputin <rasputin@submonkey.net>
  *  Radim Kolar
  *  Ralf Meister
  *  Remington Lang <MrL0Lz@gmail.com>
  *  Renaud Chaput <renchap@cocoa-x.com>
  *  Roderick van Domburg <r.s.a.vandomburg@student.utwente.nl>
  *  Roland van Laar <roland@micite.net>
  *  Romain Tartiere <romain@blogreen.org>
  *  Roman Bogorodskiy
  *  Roman Bogorodskiy <novel@FreeBSD.org>
  *  Roman Shterenzon <roman@xpert.com>
  *  Rong-En Fan <rafan@FreeBSD.org>
  *  Ryan Steinmetz <zi@FreeBSD.org>
  *  Sahil Tandon <sahil@tandon.net>
  *  Sascha Holzleiter <sascha@root-login.org>
  *  SeaD
  *  Seamus Venasse <svenasse@polaris.ca>
  *  Sean Greven <sean.greven@gmail.com>
  *  Sebastian Schuetz <sschuetz@fhm.edu>
  *  Sergei Kolobov <sergei@FreeBSD.org>
  *  Sergei Kolobov <sergei@kolobov.com>
  *  Sergei Vyshenski
  *  Sergei Vyshenski <svysh.fbsd@gmail.com>
  *  Sergey Skvortsov <skv@protey.ru>
  *  Seth Kingsley <sethk@meowfishies.com>
  *  Shaun Amott <shaun@inerd.com>
  *  Simeon Simeonov <sgs@pichove.org>
  *  Simon Dick <simond@irrelevant.org>
  *  Sofian Brabez <sbrabez@gmail.com>
  *  Stanislav Sedov <ssedov@mbsd.msk.ru>
  *  Stefan Esser <se@FreeBSD.org>
  *  Stefan Grundmann
  *  Stefan Walter <sw@gegenunendlich.de>
  *  Stephon Chen <stephon@gmail.com>
  *  Steve Wills <steve@mouf.net>
  *  Steve Wills <swills@FreeBSD.org>
  *  Steven Kreuzer
  *  Steven Kreuzer <skreuzer@exit2shell.com>
  *  Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
  *  TAKAHASHI Kaoru <kaoru@kaisei.org>
  *  TAKATSU Tomonari <tota@FreeBSD.org>
  *  Tatsuki Makino <tatsuki_makino@hotmail.com>
  *  Thibault Payet <monwarez@mailoo.org>
  *  Thierry Thomas (<thierry@pompo.net>)
  *  Thierry Thomas <thierry@pompo.net>
  *  Thomas Hurst <tom@hur.st>
  *  Thomas Quinot <thomas@cuivre.fr.eu.org>
  *  Thomas Zander <riggs@FreeBSD.org>
  *  Thomas von Dein <freebsd@daemon.de>
  *  Tilman Linneweh <arved@FreeBSD.org>
  *  Tim Bishop <tim@bishnet.net>
  *  Tom Judge <tom@tomjudge.com>
  *  Tomoyuki Sakurai <cherry@trombik.org>
  *  Toni Viemerö <toni.viemero@iki.fi>
  *  Tony Maher
  *  Torsten Zuhlsdorff <ports@toco-domains.de>
  *  Travis Campbell <hcoyote@ghostar.org>
  *  Tsung-Han Yeh <snowfly@yuntech.edu.tw>
  *  Ulf Lilleengen
  *  Vaida Bogdan <vaida.bogdan@gmail.com>
  *  Valentin Zahariev <curly@e-card.bg>
  *  Valerio Daelli <valerio.daelli@gmail.com>
  *  Veniamin Gvozdikov <vg@FreeBSD.org>
  *  Victor Popov
  *  Victor Popov <v.a.popov@gmail.com>
  *  Vsevolod Stakhov
  *  Vsevolod Stakhov <vsevolod@FreeBSD.org>
  *  Wen Heping <wen@FreeBSD.org>
  *  Wen Heping <wenheping@gmail.com>
  *  Yarodin <yarodin@gmail.com>
  *  Yen-Ming Lee <leeym@FreeBSD.org>
  *  Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
  *  Yen-Ming Lee <leeym@leeym.com>
  *  Ying-Chieh Liao <ijliao@FreeBSD.org>
  *  Yonatan <Yonatan@Xpert.com>
  *  Yonatan <onatan@gmail.com>
  *  Yoshisato YANAGISAWA
  *  Yuri Victorovich
  *  Yuri Victorovich <yuri@rawbw.com>
  *  Zach Thompson <hideo@lastamericanempire.com>
  *  Zane C. Bowers <vvelox@vvelox.net>
  *  Zeus Panchenko <zeus@gnu.org.ua>
  *  ache
  *  adamw
  *  ajk@iu.edu
  *  alex@FreeBSD.org
  *  allan@saddi.com
  *  alm
  *  andrej@ebert.su
  *  andrew@scoop.co.nz
  *  andy@fud.org.nz
  *  antoine@FreeBSD.org
  *  arved
  *  barner
  *  brix@FreeBSD.org
  *  buganini@gmail.com
  *  chinsan
  *  chris@still.whet.org
  *  clement
  *  clsung
  *  crow
  *  cy@FreeBSD.org
  *  dominik karczmarski <dominik@karczmarski.com>
  *  dwcjr@inethouston.net
  *  eivind
  *  erich@rrnet.com
  *  erwin@FreeBSD.org
  *  girgen@FreeBSD.org
  *  glen.j.barber@gmail.com
  *  hbo@egbok.com
  *  ijliao
  *  jesper
  *  jfitz
  *  johans
  *  joris
  *  kftseng@iyard.org
  *  kris@FreeBSD.org
  *  lx
  *  markm
  *  mharo@FreeBSD.org
  *  michaelnottebrock@gmx.net
  *  mnag@FreeBSD.org
  *  mp39590@gmail.com
  *  nbm
  *  nectar@FreeBSD.org
  *  nork@FreeBSD.org
  *  nork@cityfujisawa.ne.jp
  *  nsayer@FreeBSD.org
  *  nsayer@quack.kfu.com
  *  ntarmos@cs.uoi.gr
  *  oly
  *  onatan@gmail.com
  *  pandzilla
  *  patrick@mindstep.com
  *  pauls
  *  perl@FreeBSD.org
  *  petef@FreeBSD.org
  *  peter.thoenen@yahoo.com
  *  ports@c0decafe.net
  *  ports@rbt.ca
  *  roam@FreeBSD.org
  *  rokaz
  *  sada@FreeBSD.org
  *  scrappy
  *  se
  *  shane@freebsdhackers.net aka modsix@gmail.com
  *  snb@threerings.net
  *  sumikawa
  *  sviat
  *  teramoto@comm.eng.osaka-u.ac.jp
  *  thierry@pompo.net
  *  tobez@FreeBSD.org
  *  torstenb@FreeBSD.org
  *  trasz <trasz@pin.if.uz.zgora.pl>
  *  trevor
  *  truckman
  *  vanhu
  *  vanilla@
  *  wen@FreeBSD.org
  *  will

With hat:	portmgr
857c05f867
Dries Michiels (driesm) · 0.034
security/p5-Crypt-JWT: Update to 0.034

Ensure payload is serialized consistently (canonical).

PR:			260112
Approved by:		philip (mentor)
Differential Revision:	https://reviews.freebsd.org/D33201
552c9a7e73
Rainer Hurling (rhurlin) · 0.033
security/p5-Crypt-JWT: Update to 0.033

Changelog: https://metacpan.org/changes/distribution/Crypt-JWT

PR:		255568
Reported by:	Sergei Vyshenski <svysh.fbsd@gmail.com> (maintainer)
252197ba9c
Neel Chauhan (nc) · 0.032
New port: security/p5-Crypt-JWT

JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516
implements the Perl interface to:

 * JSON Web Token (JWT)
 * JSON Web Signature (JWS)
 * JSON Web Encryption (JWE)

As defined by RFC7519, RFC7515, RFC7516.

The module implements all (100%) algorithms defined in RFC7518 - JSON
Web Algorithms (JWA). This module supports Compact JWS/JWE and
flattened JWS/JWE JSON serialization, general JSON serialization
is not supported yet.

PR:		255447
Submitted by:	Sergei Vyshenski <svysh.fbsd@gmail.com>
a69f7dd95d