security/rubygem-acme-client-gitlab: update to 2.0.34 Required for gitlab 19.4. Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.md05a2121870
Port details
security/rubygem-acme-client-gitlab 2.0.34
Client for the ACME protocol
- Maintainer
- mfechner@FreeBSD.org
- Packages
- latest: 2.0.34
- Upstream
- up to date
- Last update
- to 2.0.34 · 05a2121870
- Quarterly
- 2026Q4: 2.0.34
- WWW
- https://github.com/unixcharles/acme-client
- Links
- cgit · VuXML
Unaddressed and VuXML only (0)
No unaddressed CVE and nothing reported by
pkg audit for the packaged version 2.0.34.Fixed (0)
No VuXML entries for this package.
Problem reports (0) · open in Bugzilla, most recently changed first
None.
Commits (12)
security/rubygem-acme-client-gitlab: update to 2.0.32 Required for gitlab 19.2.0 Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.mdc03c64ceb4
security/rubygem-acme-client-gitlab: update to 2.0.31 Required for gitlab 18.11 Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.mdafd6947151
security/rubygem-acme-client-gitlab: update to 2.0.30 Required for gitlab 18.8 Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.mdbb44b2dd8b
security/rubygem-acme-client-gitlab: update to 2.0.26 Required for gitlab 18.5 Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.md8e4ece9800
security/rubygem-acme-client-gitlab: Change RUN_DEPENDS from rubygem-base6402 to rubygem-base64 - Bump PORTREVISION for dependency change acme-client changes from 'base64 ~> 0.2.0' to 'base64 ~> 0.2' since 2.0.22. Approved by: portmgr (blanket) With hat: ruby3f41d08d4e
security/rubygem-acme-client-gitlab: update to 2.0.25 Required for gitlab 18.3 Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.md59f10759b7
security/rubygem-acme-client-gitlab: update to 2.0.22 Required for gitlab 18.2 Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.md2fdf986896
security/rubygem-acme-client-gitlab: Change RUN_DEPENDS from rubygem-base64 to rubygem-base6402 - Bump PORTREVISION for dependency change997b11cee0
security/rubygem-acme-client-gitlab: update to 2.0.21 Required for gitlab 17.11 Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.md05e5275735
security/rubygem-acme-client-gitlab: update to 2.0.20 Changes: https://github.com/unixcharles/acme-client/blob/master/CHANGELOG.md956ad7f948
www/gitlab: fix regression from 335fc7c38d61142727cb9f01fd9e401c476e4ad8 Gitlab requires net-http 0.4.1: Because faraday >= 2, < 2.5 could not be found in locally installed gems and faraday >= 2.5, < 2.12.1 could not be found in locally installed gems, faraday >= 2, < 2.12.1 cannot be used. And because faraday >= 2.12.1 depends on faraday-net_http >= 2.0, < 3.5, faraday >= 2 requires faraday-net_http >= 2.0, < 3.5. Because faraday-net_http >= 3.4.0 depends on net-http >= 0.5.0 and faraday-net_http >= 2.0, < 3.4.0 could not be found in locally installed gems, faraday-net_http >= 2.0 requires net-http >= 0.5.0. Thus, faraday >= 2 requires net-http >= 0.5.0. So, because Gemfile depends on faraday ~> 2 and Gemfile depends on net-http = 0.4.1, version solving has failed. While fixing the problem, moved gitlab used packages to own package names with a PKGNAMESUFFIX of `-gitlab`. This should make the gitlab package much more stable if updates in the ports are done.edc8d0390e