textproc/rubygem-rouge-gitlab: update to 5.1.0 Required for gitlab 19.4. Changes: https://github.com/rouge-ruby/rouge/blob/master/CHANGELOG.md14aff1d9b0
Port details
textproc/rubygem-rouge-gitlab 5.1.0
Simple, easy-to-extend drop-in replacement for pygments
- Maintainer
- mfechner@FreeBSD.org
- Packages
- latest: 5.1.0
- Upstream
- up to date
- Last update
- to 5.1.0 · 14aff1d9b0
- Quarterly
- 2026Q4: 5.1.0
- WWW
- https://github.com/jneen/rouge
- Links
- cgit · VuXML
Unaddressed and VuXML only (0)
No unaddressed CVE and nothing reported by
pkg audit for the packaged version 5.1.0.Fixed (0)
No VuXML entries for this package.
Problem reports (0) · open in Bugzilla, most recently changed first
None.
Commits (8)
textproc/rubygem-rouge-gitlab: update to 5.0.0 Required for gitlab 19.3 Changes: https://github.com/rouge-ruby/rouge/blob/master/CHANGELOG.mdb68a3efd6f
textproc/rubygem-rouge-gitlab: update to 4.7.0 Required for gitlab 18.8 Changes: https://github.com/rouge-ruby/rouge/blob/master/CHANGELOG.md41b4dd6b5e
textproc/rubygem-rouge-gitlab: update to 4.6.1 Required for gitlab 18.5 Changes: https://github.com/rouge-ruby/rouge/blob/master/CHANGELOG.md2a159b7dac
textproc/rubygem-rouge-gitlab: update to 4.6.0 Required for gitlab 18.3 Changes: https://github.com/rouge-ruby/rouge/blob/master/CHANGELOG.mdbfbcedcb96
textproc/rubygem-rouge-gitlab: update to 4.5.2 Required for gitlab 18.1 Changes: https://github.com/rouge-ruby/rouge/blob/master/CHANGELOG.md204bebe4a1
textproc/rubygem-rouge-gitlab: update to 4.5.1 Required for gitlab 17.9 Changes: https://github.com/rouge-ruby/rouge/blob/master/CHANGELOG.md18ec5bfb0b
www/gitlab: fix regression from 335fc7c38d61142727cb9f01fd9e401c476e4ad8 Gitlab requires net-http 0.4.1: Because faraday >= 2, < 2.5 could not be found in locally installed gems and faraday >= 2.5, < 2.12.1 could not be found in locally installed gems, faraday >= 2, < 2.12.1 cannot be used. And because faraday >= 2.12.1 depends on faraday-net_http >= 2.0, < 3.5, faraday >= 2 requires faraday-net_http >= 2.0, < 3.5. Because faraday-net_http >= 3.4.0 depends on net-http >= 0.5.0 and faraday-net_http >= 2.0, < 3.4.0 could not be found in locally installed gems, faraday-net_http >= 2.0 requires net-http >= 0.5.0. Thus, faraday >= 2 requires net-http >= 0.5.0. So, because Gemfile depends on faraday ~> 2 and Gemfile depends on net-http = 0.4.1, version solving has failed. While fixing the problem, moved gitlab used packages to own package names with a PKGNAMESUFFIX of `-gitlab`. This should make the gitlab package much more stable if updates in the ports are done.edc8d0390e