version as in the ports tree (latest) or the most common one (quarterly) · different version · ✗ not built · – no packages for this platform. Package sets that have not been rebuilt for 60 days are left out.
Unaddressed and VuXML only (0)
No unaddressed CVE and nothing reported by pkg audit for the packaged version 1.70.0.
Fixed (6)
Show 6 fixed
VuXML entries whose affected range the packaged version has left.
Problem reports (0) · open in Bugzilla, most recently changed first
None.
Commits (191)
Gerald Pfeifer (gerald) · 1.25.0_1
Bump PORTREVISION for ports depending on the canonical version of GCC (via Mk/bsd.default-versions.mk and lang/gcc) which has moved from GCC 5.4 to GCC 6.4 under most circumstances.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang,
c++14-lang, c++0x, c11, or gcc-c++11-lib.
PR: 219275
Bump PORTREVISIONs for ports depending on the canonical version of GCC and lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some circumstances such as versions of FreeBSD or platforms).
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using using Mk/bsd.octave.mk which in turn has USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang,
c++11-lang, c++0x, c11, or gcc-c++11-lib.
PR: 216707
devel/libevent2: update to 2.1.8 and cleanup
- DEFAULT_VERSIONS += ssl=openssl-devel is now supported
- devel/py-event and devel/p5-Event-Lib are marked BROKEN
Changes: https://github.com/libevent/libevent/raw/release-2.1.8-stable/whatsnew-2.1.txt
Changes: https://github.com/libevent/libevent/raw/release-2.1.8-stable/ChangeLog
PR: 216527
Exp-run by: antoine
Approved by: mm (maintainer)
Assume "pkg-config zlib" works after 9.x reached EOL
Many ports passed ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-L/usr/lib -lz"
which is unsafe at least with lang/gcc* that override some system headers
and have newer libgcc_s.so that our old version in base may not be
forward-compatible with.
- Update to 1.18.0 - Add BUILD_DEPENDS: make sure using same version libnghttp2 - Remove ASIO_RUN_DEPENDS: BUILD_DEPENDS is sufficient to block unqualified version
Changes: https://github.com/nghttp2/nghttp2/releases
- Update for libnghttp2 change (moved into www/libnghttp2) - Add LIB_DEPENDS on www/libnghttp2 - Copy libnghttp2 to lib/ to avoid unnecessary rebuild - Bump PORTREVISION for dependency and package change
Use USES=pathfix where applicable.
PR: 213195
Submitted by: mat
Exp-run by: antoine
Sponsored by: Absolight
Differential Revision: https://reviews.freebsd.org/D8093