mail/p5-MIME-Types: update to 2.2992dc2f5402
Port details
mail/p5-MIME-Types2.29
Perl extension for determining MIME types
- Maintainer
- perl@FreeBSD.org
- Packages
- p5-MIME-Types 2.29
- Upstream
- Higher version available: 2.30
- CPE
- none, CVEs only via VuXML
- WWW
- https://metacpan.org/release/MIME-Types
- Links
- cgit · VuXML
Unaddressed (0) · The CVE record lists this version as affected, no VuXML entry names the CVE
None. There is no CVE without a VuXML entry for this version.
VuXML only (0) · listed, port not fixed yet
None.
pkg audit reports nothing for this version.Fixed (0)
No VuXML entries for this package.
Commits (67)
mail/p5-MIME-Types: update to 2.28
Changelog: https://metacpan.org/dist/MIME-Types/changes
Major changes:
* some 'deprecated' texts made it to types.db.
* text/ecmascript RFC9239
* default charsets according to RFC6657
* update reference to specs RFC6838 and RFC9694
* iana updates46b569ab08mail/p5-MIME-Types: Update to 2.277e589b497d
mail/p5-MIME-Types: update to 2.26 Changelog: https://metacpan.org/release/MARKOV/MIME-Types-2.26/source/ChangeLogb8e4681646
mail/p5-MIME-Types: Update to 2.24 Changes: https://metacpan.org/dist/MIME-Types/changesb2b1a52512
Remove WWW entries moved into port Makefiles Commit b7f05445c00f has added WWW entries to port Makefiles based on WWW: lines in pkg-descr files. This commit removes the WWW: lines of moved-over URLs from these pkg-descr files. Approved by: portmgr (tcberner)fb16dfecae
Add WWW entries to port Makefiles It has been common practice to have one or more URLs at the end of the ports' pkg-descr files, one per line and prefixed with "WWW:". These URLs should point at a project website or other relevant resources. Access to these URLs required processing of the pkg-descr files, and they have often become stale over time. If more than one such URL was present in a pkg-descr file, only the first one was tarnsfered into the port INDEX, but for many ports only the last line did contain the port specific URL to further information. There have been several proposals to make a project URL available as a macro in the ports' Makefiles, over time. This commit implements such a proposal and moves one of the WWW: entries of each pkg-descr file into the respective port's Makefile. A heuristic attempts to identify the most relevant URL in case there is more than one WWW: entry in some pkg-descr file. URLs that are not moved into the Makefile are prefixed with "See also:" instead of "WWW:" in the pkg-descr files in order to preserve them. There are 1256 ports that had no WWW: entries in pkg-descr files. These ports will not be touched in this commit. The portlint port has been adjusted to expect a WWW entry in each port Makefile, and to flag any remaining "WWW:" lines in pkg-descr files as deprecated. Approved by: portmgr (tcberner)b7f05445c0
mail/p5-MIME-Types: Update to 2.22 Changes: https://metacpan.org/dist/MIME-Types/changes37c670dc61
mail/p5-MIME-Types: Update to 2.21f2ed8c38d0
mail/p5-MIME-Types: Update to 2.20 Changes: https://metacpan.org/changes/distribution/MIME-Types76fddcf3cb
One more small cleanup, forgotten yesterday. Reported by: lwhsucf118ccf87
Remove # $FreeBSD$ from Makefiles.305f148f48
Update to 2.18 Changes: https://metacpan.org/changes/distribution/MIME-Typesbbb0e427ba
Update WWW search.cpan.org is shutting down. It will redirect to metacpan.org after June 25, 2018. With hat: perlad4f267b7a
Update to 2.17 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLog270390dea2
Update to 2.16 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLog88df0576ab
Update to 2.14 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLogf936822137
Fix license information for portgs that use "the same license as Perl". Sponsored by: Absolightcb41fc6623
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.
With hat: portmgr
Sponsored by: Absolight8d6597e0bbUpdate to 2.13. Add Mojolicious to TEST_DEPENDS. Changes: https://metacpan.org/changes/distribution/MIME-Typesc28c5d9edc
- Update to 2.12 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLoged89a7204a
- Update to 2.11 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLoga036215104
- Update to 2.10 - Add NO_ARCH - Sort PLIST Changes: http://search.cpan.org/dist/MIME-Types/ChangeLogb61379de6d
Change the way Perl modules are installed, update the default Perl to 5.18. Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgreee58d187e
- Update to 2.09 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLog65d62df3cf
- Update to 2.0892bbc7c03e
- Update to 2.06 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLogbd5e085637
Support STAGEDIR.882b641c0d
Add NO_STAGE all over the place in preparation for the staging support (cat: mail)fd61959c15
- Update to 2.04 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLogc4c8d4b72f
Update to 2.03. Changes: http://search.cpan.org/dist/MIME-Types/ChangeLog31eeb4d866
- Convert to new perl framework - Trim Makefile header - Remove MAKE_JOBS_SAFE=yes, it's the default.4819ca343b
Update to 1.38. Changes: http://search.cpan.org/dist/MIME-Types/ChangeLogc8acfa439a
Update to 1.37. Changes: http://search.cpan.org/dist/MIME-Types/ChangeLogfb8786c3d7
- Update to 1.36 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLog Feature safe: yes08c03cdd72
- Update to 1.35 - Add LICENSE (Artistic 1 & GPL 1) Changes: http://search.cpan.org/dist/MIME-Types/ChangeLog414acad0d1
- Update to 1.34 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLog5fc3d9287c
- Update to 1.32 Changes: http://search.cpan.org/dist/MIME-Types/ChangeLog45fb334d03
- Cleaning MD5 in perl@'s ports Approved by: erwin@ (portmgr)354b25a277
- Update to 1.31 PR: ports/150850 Submitted by: Frederic Culot <frederic@culot.org> With Hat: perl@ Changes: http://search.cpan.org/dist/MIME-Types/Changes5a1d4214d2
- Update to 1.30 - Change MAINTAINER to perl@ Changes: http://search.cpan.org/src/MARKOV/MIME-Types-1.30/ChangeLog6f46c75fa7
Update to 1.29 Changes: http://cpansearch.perl.org/src/MARKOV/MIME-Types-1.29/ChangeLog PR: ports/145345 Submitted by: maxba012becc0
Update to 1.28 Changes: http://cpansearch.perl.org/src/MARKOV/MIME-Types-1.28/ChangeLog Feature safe: yesa5c69dd055
Update to 1.27 Changes: http://cpansearch.perl.org/src/MARKOV/MIME-Types-1.27/ChangeLogabe34fe6de
Update to 1.26 Changes: http://cpansearch.perl.org/src/MARKOV/MIME-Types-1.27/ChangeLog PR: ports/131395 Submitted by: pgollucci4b4902e77b
Update to 1.25 Changes: http://search.cpan.org/src/MARKOV/MIME-Types-1.25/ChangeLog64406f240d
Update to 1.24 PR: ports/124368 Submitted by: leeym Changes: http://search.cpan.org/src/MARKOV/MIME-Types-1.24/ChangeLogbd5626a621
- Take advantage of CPAN macro from bsd.sites.mk, change ${MASTER_SITE_PERL_CPAN} to CPAN.
PR: ports/122674
Submitted by: Philip M. Gollucci <pgollucci@p6m7g8.com>
Reworked by: araujo (myself)
Approved by: portmgr (pav)4aaab89f57Update to 1.23 Changes: http://search.cpan.org/src/MARKOV/MIME-Types-1.23/ChangeLog41c8718f1e
Update to 1.21 Changes: http://search.cpan.org/src/MARKOV/MIME-Types-1.21/ChangeLog3d48274128