net/rubygem-google-cloud-storage-gitlab: update to 1.62.0 Required for gitlab 19.4. Changes: https://github.com/googleapis/google-cloud-ruby/blob/main/google-cloud-storage/CHANGELOG.md26f7ed3d41
Port details
net/rubygem-google-cloud-storage-gitlab 1.62.0
Official library for Google Cloud Storage
- Maintainer
- mfechner@FreeBSD.org
- Packages
- latest: 1.62.0
- Upstream
- up to date
- Last update
- to 1.62.0 · 26f7ed3d41
- Quarterly
- 2026Q4: 1.62.0
- WWW
- https://cloud.google.com/ruby/docs/reference/google-cloud-storage/latest/
- Links
- cgit · VuXML
Unaddressed and VuXML only (0)
No unaddressed CVE and nothing reported by
pkg audit for the packaged version 1.62.0.Fixed (0)
No VuXML entries for this package.
Problem reports (0) · open in Bugzilla, most recently changed first
None.
Commits (3)
net/rubygem-google-cloud-storage-gitlab: update to 1.57.0 Required for gitlab 18.4.3 Changes: https://github.com/googleapis/google-cloud-ruby/blob/main/google-cloud-storage/CHANGELOG.md8038345373
www/gitlab: fix regression from 335fc7c38d61142727cb9f01fd9e401c476e4ad8 Gitlab requires net-http 0.4.1: Because faraday >= 2, < 2.5 could not be found in locally installed gems and faraday >= 2.5, < 2.12.1 could not be found in locally installed gems, faraday >= 2, < 2.12.1 cannot be used. And because faraday >= 2.12.1 depends on faraday-net_http >= 2.0, < 3.5, faraday >= 2 requires faraday-net_http >= 2.0, < 3.5. Because faraday-net_http >= 3.4.0 depends on net-http >= 0.5.0 and faraday-net_http >= 2.0, < 3.4.0 could not be found in locally installed gems, faraday-net_http >= 2.0 requires net-http >= 0.5.0. Thus, faraday >= 2 requires net-http >= 0.5.0. So, because Gemfile depends on faraday ~> 2 and Gemfile depends on net-http = 0.4.1, version solving has failed. While fixing the problem, moved gitlab used packages to own package names with a PKGNAMESUFFIX of `-gitlab`. This should make the gitlab package much more stable if updates in the ports are done.edc8d0390e