www/gitlab: major upgrade to 18.4.3 Changes: https://about.gitlab.com/releases/2025/09/18/gitlab-18-4-released/b4e64ecafd
Port details
security/rubygem-googleauth-gitlab 1.14.0_2
Google Auth Library for Ruby
- Maintainer
- mfechner@FreeBSD.org
- Packages
- latest: 1.14.0_2
- Upstream
- up to date
- Last update
- to 1.14.0_2 · b4e64ecafd
- Quarterly
- 2026Q4: 1.14.0_2
- WWW
- https://github.com/googleapis/google-auth-library-ruby
- Links
- cgit · VuXML
Unaddressed and VuXML only (0)
No unaddressed CVE and nothing reported by
pkg audit for the packaged version 1.14.0_2.Fixed (0)
No VuXML entries for this package.
Problem reports (0) · open in Bugzilla, most recently changed first
None.
Commits (4)
security/rubygem-googleauth-gitlab: Change RUN_DEPENDS from rubygem-jwt to rubygem-jwt2 - Bump PORTREVISION for dependency change98c536e78d
security/rubygem-googleauth-gitlab: update to 1.14.0 Required for gitlab 18.3 Changes: https://github.com/googleapis/google-auth-library-ruby/releasescd4d6c724d
www/gitlab: fix regression from 335fc7c38d61142727cb9f01fd9e401c476e4ad8 Gitlab requires net-http 0.4.1: Because faraday >= 2, < 2.5 could not be found in locally installed gems and faraday >= 2.5, < 2.12.1 could not be found in locally installed gems, faraday >= 2, < 2.12.1 cannot be used. And because faraday >= 2.12.1 depends on faraday-net_http >= 2.0, < 3.5, faraday >= 2 requires faraday-net_http >= 2.0, < 3.5. Because faraday-net_http >= 3.4.0 depends on net-http >= 0.5.0 and faraday-net_http >= 2.0, < 3.4.0 could not be found in locally installed gems, faraday-net_http >= 2.0 requires net-http >= 0.5.0. Thus, faraday >= 2 requires net-http >= 0.5.0. So, because Gemfile depends on faraday ~> 2 and Gemfile depends on net-http = 0.4.1, version solving has failed. While fixing the problem, moved gitlab used packages to own package names with a PKGNAMESUFFIX of `-gitlab`. This should make the gitlab package much more stable if updates in the ports are done.edc8d0390e