version as in the ports tree (latest) or the most common one (quarterly) · different version · ✗ not built · – no packages for this platform. Package sets that have not been rebuilt for 60 days are left out.
Unaddressed (0)
The CVE record lists the packaged version 24.21.0_3 as affected, and no VuXML entry names the CVE. What does this mean?
None.
VuXML only (1)
Listed in VuXML, the packaged version 24.21.0_3 is still in the affected range; pkg audit reports it. What does this mean?
www/node*: fix build on non-amd64/-i386 when BUNDLED_SSL is unset
The --openssl-no-asm configure option should only be set
when BUNDLED_SSL is enabled.
PR: 235311
Reported by: jbeich
Sponsored by: Miles AS
www/node: Update 11.8.0 -> 11.9.0
Update patches and pkg-plist for deps/openssl/**/* after upstream
pdated to OpenSSL 1.1.1a and refresh existing patches with
`make makepatch`.
https://nodejs.org/en/blog/release/v11.9.0/
Sponsored by: Miles AS
www/node: disable BUNDLED_SSL by default on FreeBSD >=12
Change the default options on FreeBSD >=12 since OpenSSL 1.1.1 is
available in the base system. Bump PORTREVISION due to the change in
defaults.
While here, convert the port to use BROKEN_SSL, taking care to set
BROKEN_SSL+=base when appropriate.
PR: 234762
Reported by: amdmi3
Sponsored by: Miles AS
Bump PORTREVISION for ports depending on the canonical version of GCC defined via Mk/bsd.default-versions.mk which has moved from GCC 7.4 t GCC 8.2 under most circumstances.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, as a double check, everything INDEX-11 showed depending on lang/gcc7.
PR: 231590
www/node: Update 11.2.0 -> 11.3.0
This is a security release that addresses multiple vulnerabilities. Users
are recommended to upgrade as soon as possible.
https://nodejs.org/en/blog/vulnerability/november-2018-security-releases/
https://nodejs.org/en/blog/release/v11.3.0/
MFH: 2018Q4
Security: 2a86f45a-fc3c-11e8-a414-00155d006b02
Sponsored by: Miles AS
Remove compatibility code for FreeBSD < 11.2 from all ports.
Simplify some ports where DragonFlyBSD no longer needs to be special-cased.
Submitted by: rene
Reviewed by: bapt, jbeich
Differential Revision: https://reviews.freebsd.org/D17724
www/node: Update 10.12.0_1 -> 11.0.0
Update to the latest major release of Node.js. Upstream has dropped
support for FreeBSD 10.x, so mark the port as BROKEN on FreeBSD 10.
Regenerate patches with `make makepatch`.
https://nodejs.org/en/blog/release/v11.0.0/
Sponsored by: Miles AS
www/node10: copy from www/node, update 10.12.0_1 -> 10.13.0 (LTS)
Create a new port for the latest Node.js 10.13.0 LTS release. Update
CONFLICTS for the existing Node.js ports to include the new node10 port
and remove non-existent ports.
https://nodejs.org/en/blog/release/v10.13.0/
Sponsored by: Miles AS
www/node: add dependency on www/libnghttp2
... instead of using the bundled version. Bump PORTREVISION due to the
new dependency.
Sponsored by: Miles AS
www/node: Update 10.7.0_1 -> 10.9.0
This is a security release addressing multiple vulnerabilities. Users
are recommended to upgrade as soon as possible.
https://nodejs.org/en/blog/vulnerability/august-2018-security-releases/
https://nodejs.org/en/blog/release/v10.9.0/
While here, refresh patches with `make makepatch`
MFH: 2018Q3
Security: 0904e81f-a89d-11e8-afbb-bc5ff4f77b71
Sponsored by: Miles AS
Bump PORTREVISION for ports depending on the canonical version of GCC in the ports tree (via Mk/bsd.default-versions.mk and lang/gcc) which has now moved from GCC 6 to GCC 7 by default.
This includes ports
- featuring USE_GCC=yes or USE_GCC=any,
- featuring USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and those
- with USES=compiler specifying one of openmp, nestedfct, c11, c++0x,
c++11-lib, c++11-lang, c++14-lang, c++17-lang, or gcc-c++11-lib.
PR: 222542
www/node: Update 10.3.0 -> 10.4.0
https://nodejs.org/en/blog/release/v10.4.0/
Remove files/patch-deps_v8_src_base_cpu.cc, which has been applied
upstream and is no longer necessary (as reported in PR 228779). Other
patches have been refreshed as needed with `make makepatch`.
PR: 228779
Reported by: Sylvain Garrigues <sylvain@sylvaingarrigues.com>
Sponsored by: Miles AS
www/node: fix build on i386
Add patch files missing from r469781, which ensure that the Node.js
build on i386 falls back to the linux-elf OpenSSL config.
PR: 228135
Reported by: Marcin Cieslak <saper@saper.info>
www/node: fix SSL/TLS on i386
The upgrade to v10.0.0 included significant changes to the OpenSSL
dependency in Node.js, in particular how the build was configured.
Upstream does not include a BSD-x86 config anymore, so the www/node port
ended up using the BSD-x86_64 no-asm config for all builds except x86_64
(which used the asm optimized config). This was a mistake, causing all
32-bit archs to build OpenSSL configured for a 64-bit architecture, and
it causes problems with SSL/TLS as described in PR 228135.
Change the build config to not use BSD-x86_64 no-asm for 32-bit i386 and
arm builds, falling back to the generic linux-elf configuration instead.
Patches remove Linux specific libraries (-ldl) and keep the CFLAGS the
same as the BSD config.
PR: 228135
Reported by: Marcin Cie\xc5\x9blak <saper@saper.info>
www/node: Update 9.11.1_1 -> 10.0.0
Update to the latest major release of Node.js. This release includes
many significant changes, both to Node.js itself and the FreeBSD port.
https://nodejs.org/en/blog/release/v10.0.0/
In particular, Node.js now requires OpenSSL 1.1.0h, so the BUNDLED_SSL
option is enabled by default. It is still possible to disable this
option when using security/openssl-devel (which is currently at 1.1.0h).
Multiple patches are required to get Node.js building with the bundled
OpenSSL library. Only amd64 builds get optimized assembler; all other
archs use non-asm implementations.
www/node: Update 9.10.0 -> 9.10.1
No changes from the previous verison. This release ensures that the
hosted binaries from the Node.js project adhere to the platform support
contract, which does not apply to the FreeBSD port and packages.
MFH: 2018Q2
www/node: Update 9.9.0 -> 9.10.0
This is a security release addressing multiple vulnerabilities. Users
are recommended to upgrade as soon as possible.
https://nodejs.org/en/blog/vulnerability/march-2018-security-releases/
https://nodejs.org/en/blog/release/v9.10.0/
MFH: 2018Q1
Security: 5a9bbb6e-32d3-11e8-a769-6daaba161086
www/node: Update 9.7.0 -> 9.7.1
There are not changes in the release. A new version was published due to
a bad node-v9.7.0.pkg (macOS installer) file that was published to
nodejs.org in the previous release.
https://nodejs.org/en/blog/release/v9.7.1/
Mark www/node as buildable by powerpc64
Summary:
As of node 9.3.0, a bug was fixed preventing builds with gcc. As this has
not been tested on mips, and fails on powerpcspe, only add powerpc64 to the
ONLY_FOR_ARCHS list.
Test Plan: Built for powerpc64
Reviewed By: bhughes
Differential Revision: https://reviews.freebsd.org/D13880
www/node,www/node8,www/node6: disable dtrace usdt on armv[67]
Disable the DTRACE option by default on armv[67] since Node.js fails to
build on armv[67] with the following error:
dt_modtext:/usr/src/cddl/contrib/opensolaris/lib/libdtrace/common/dt_link.c(820): arm not implemented
PR: 224271
Submitted by: mikael.urankar@gmail.com